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Click any of the Headings above to go directly to that subject.
There are some web page links in the document. Click these and your browser should open 
and take you to that web page. Use Back to return.
This manual has been written as if you are a complete novice on spreadsheets (my apologies to 
experts). Easy-Pro has been designed so that you don't need to be proficient with them and 
after reading this manual you will be familiar with it's functions.
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Installation and Setup
The downloaded file is a self installer that will unzip all the relevant files into the directory 
c:\BuildnQuote\ or you may have chosen another directory area. The important file is Easy-
Pro Estimator V8_0.ots This is the main template file for you to copy off and use for your 
estimating.

You probably want to store your estimates elsewhere, so below is an example of a possible 
directory tree for a building company.

C:\User\Documents\Building Coy\Accounting
\Correspondence
\Estimates Quotes\Smith St

\Logan Rd
\Mastercopies\Documents

\Estimating
\OHS
\Suppliers
\Taxation
\Work in Progress\Porter St

\Camp Cresc
\Completed Work 

So with this set up we would copy the following files into ….\Mastercopies\Estimating
Easy-Pro EstimatorV8_0.ots      spreadsheet template
Trade Prices.odd database
Trade Suppliers Prices.ods spreadsheet
Easy-Pro Users Manual.pdf pdf 

You can leave all the others and just read them from the buildnquote directory.

Macros Setting
If you have not already done so, you need to set the OpenOffice program to allow Macros at 
Medium. To do this start a spreadsheet in openoffice and go to the top toolbar then select 
Tools → Options → OpenOffice.org → Security → Macro security then select Medium and 
Okay.

Now got to ….\Mastercopies\Estimating and double click  Easy-Pro EstimatorV8_0.ots
This should start to open then it will ask you to accept macros with a warning. Select Yes 
and the program will load. The program has macro buttons throughout, so from the 
Summary page, click a few buttons and take it for a whirl.

Program Overview
The Summary is the home page of the program. All the Trade Worksheets report back to 
here with the estimates and invoice entries. From the Summary you can access every sheet 
quickly via a macro button. Then from any sheet you will find a Summary button to bring 
you back again. These macros really speed up your estimating time. On each Worksheet 
there is a save button which you should push a lot. On some Worksheets, like Carpenter, 
there are multiple buttons that take you to a number of sheets that interact with that trade.  
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Save and Backup
Now would be a good time to make a few copies of this file. Click File →  Save As and 
change the name to Blank Mastercopy1 or whatever. You should also back up all the 
BuildnQuote files and burn them to CD.

Backing up your work is very important. I am always amazed when builders contact me to 
say that their system crashed and they lost all their files and need the program sent to them. 
It's not so much the original file that is important, but rather all the estimating work that has 
been done on it.

There are 2 important things you need to do. First when you are doing an estimate, push 
Save every 5 minutes or so and I will explain how to set up auto backup later on. Especially 
push Save when you have just entered some figures after spending a lot of time on the plan 
calculating them. Computers and programs can crash at any time, so why risk losing the last 
30 minutes of estimating just because you did not save it. OpenOffice has a very neat 
recovery process after a crash but you will still lose a bit of data if you have not saved 
frequently.

Secondly you need a backup system for all your important files. USB external hard drives 
are cheap now so these are a great way to backup your entire hard drive. Networking 2 
computers is also a good way as you can easily send the files to the other pc. Another good 
trick is to open a Google Gmail account. Then you can just email files to yourself. Gmail 
has huge storage so these files are stored in your inbox and if your office was destroyed by 
fire, or pc's stolen, then you still have your important files in Gmail. 

Emailing the file is quite simple. On the 2nd top toolbar 4th along is Document as Email. 
Click this and it sends it as an email attachment via your default email program. Send it to 
your Gmail account for backup. 

Computer Hardware
OpenOffice is a great program in that it does not create monster files like Excel. In its 
current form Easy-Pro would run like a dog in Excel yet in OO it its fast and efficient and 
the file stays relatively small, even after all the data of multi million dollar jobs have been 
entered. So you do not need the latest turbo charged pc to run it. In fact old XP machines 
will do just fine. OO will also run on Linux so if you have a pc on Ubuntu with OO you can 
use the same Easy-Pro file in Windows or Linux. Changing say a slow old laptop to Ubuntu 
will really speed it up and Ubuntu linux has become a pretty slick operating system. It is 
also a handy backup system to have even if it is just on boot CD, as Ubuntu will enable you 
to boot a pc and then access all the windows directories to recover any files from a crashed 
windows system.

Using two monitors at once is a great way to work when estimating. For instance you can 
have a previous estimate up on one and the new pricing job on the other and then just 
compare and copy paste any similar pricing figures. To run two screens there is a handy 
program called Ultramon from www.realtimesoft.com 
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Recommended OpenOffice Settings
With the Easy-Pro program open on screen. At the top tool bar go  to Tools → Options. 
This is where you can setup all the various options as to how you want OpenOffice to run. 
Lets do a quick run through. Use the default settings plus these changes.
OpenOffice.org

User Data – Fill in the details of your business.
Paths – You may want to change the path for your Templates and Backups
Security – Macro security should be set to medium
Java – Should be enabled
Online Update - Check for updates regularly, say weekly. Uncheck auto 
download.

Load Save
General/Save – Tick Always create backup copy. Tick Save Autorecovery 
information every – say 5 minutes (or less)

Language Settings
Languages – Default language for documents. Choose English USA that way 
the spell checker will work. If you choose Aussie then it is complex to get the 
spell checker to work. Then just ignore their bad spelling of words like color.

OpenOffice.org Calc 
View -  Untick off Grid lines as the Estimator will appear a lot neater for you 
and the grid lines have been coloured for the areas that you will be working in.

Value highlighting -  If you tick this on then go Okay, the program will 
show in grey all the protected cells and the ones that you can make 
entries in. Untick and Okay to go back to normal view.
Zero Values -  Untick off.
Display formulas -  Untick off.

Calculate  - If you find your dates are going a bit funny by 2 days then the 
problem can be here. See how the default date is 2 days behind the Star Office 
date. This can happen if you import in a Star file and start using it with the 
default date or visa versa.

Click Okay to close the Options and save your settings. Now save your Estimator.

Protection
The Summary page is protected with a password both for commercial reasons and to 
protect from accidental messing up of the formulas on this important page.
Most of the other pages have protection turned on but with no password. So you can turn 
off protection and add rows etc if you have to. But if you do do this you should then copy 
and paste in the formulas from the other existing cells.
If you do turn protection off, it can be a good idea to turn on Value Highlighting in 
Options. You will then be able to see the calcs done by a formula in light green. After 
making any adjustments with protection off it is a good idea to turn it back on. Just leave 
the password block blank when you do so.

To access Protection on/off go to Tools → Protect Document → Sheet
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Notes and Comments
Throughout the program you will see cells with a red dot in the right top corner. Put you 
mouse on these and a help note will pop up.

You can add your own notes to cells by selecting a cell and right click mouse and select 
Insert Note. Then just type in what you want to say. Click out of the cell to close the note. 
To edit the note right click and select Show. Now edit and adjust borders, or move position 
of note, then right click and untick Show, then click away from cell. Adding notes to items 
in your estimating can be of great benefit to yourself or staff if the estimate on the item 
needs more in depth explanation but it does so by not messing up the estimate by writing in 
cells underneath.

Notes can also be accessed on the tool bar by Insert → Note 

Template Master Copy 
Start up the blank template file Easy-Pro EstimatorV8_0.odt. It should open as an 
Untitled.ods spreadsheet (but on one of my pc's it still opens as the template file - maybe a 
vista issue?) No matter what format it opens in, now go to File → Templates → Save 
Select → My Templates and type in a name like Master Pricing Template and save. Now 
you are working on your main pricing template file that you will update with all your 
material prices and set up the pricing program how you like it. Do some entries to this now 
like say go to the Details page and fill in your company information. Now save again and 
go File → Close. 

Then go to File → New → Templates → Templates Box → My Templates and select the 
Master Pricing Template file to open.  It will open as an Untitled.ods spreadsheet ready for 
you to price your next job on. Immediately save it as  your next job like “34 Smith St” into 
the ….\Work in Progress\Smith St\ directory. Then proceed to do some estimating and 
saving as you do.  The next time you want to work on the 34 Smith St estimate just go to 
the ...\Smith St\ directory and double click the file. Or on vista Windows Start → Recent 
Items and it may be there.

Updating and Editing your Master Pricing Template.odt file  
Open it up via the Template area and it opens as an Untitled.ods file. Now go to File → 
Templates → My Templates and click on the  Master Pricing Template.odt name then save 
over it. You are now working on your  Master Pricing Template again and you can upgrade 
it with all your new pricing etc and saving as you do. Don't make the mistake of starting to 
estimate a new job onto your Master Pricing Template. Always close it and then reopen it 
as an Untitled.ods file before starting a job estimate. Make sure you keep backups of the 
Master Pricing Template. I do this by saving a few as  Master Pricing Template_1  Master 
Pricing Template_2 etc. Again email one to your Gmail account for backup.

If you have not already done so at install. You should put OpenOffice.org in your Quick 
Start or Desktop area. To do this go to START → All Programs → OpenOffice.org 3.0 
then mouse on the top program  → OpenOffice.org.  Right click and select Quick Start. 
Now the program is in your quick start area. To open your Master Pricing Template file 
just go to Quick Start →  OpenOffice.org and it will open a box with all the various 
OpenOffice.org Suite programs and a Templates box.  Click Templates → My Templates 
and double click the Master Pricing Template file to open a new Untitled.ods file ready for 
your next job.
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What I sometimes do when estimating is have 3 files running at once. The current estimate 
I am working on, a previous job I am referring to and the Master Pricing Template. Then if 
I am getting new prices on stuff I update the  Master Pricing Template file as I go. To stop 
confusion as to which file is which I have a good trick for you and you should do this with 
each new job anyway. On the Summary page you can change the colour of the Worksheet 
cells from Preliminaries to Spare 4. Just click Preliminaries and highlight down to Spare 4. 
Now go to the Background Colour Tab on the 3rd Toolbar at the top and select a very 
different colour or even black, then save. After making adjustments to say the  Master 
Pricing Template file always take it back to the Summary page before shrinking it off 
screen. Now you won't be so likely to get them mixed up.

Data Sources for Materials Pricing Lookup
View Data Sources
Database Data Sources – This is extremely handy and worth the effort to setup
Access by clicking the Database button on the Summary page or key press F4 for On/Off, 
or the Data Sources button on the Main tool bar. Learn this function and what you can do 
with it as it is very useful when set up properly. 
The Data Sources feature allows you to keep a seperate spreadsheet of all your trades 
suppliers materials, services and costs. Then you are able to call up this information in a 
window above your costings. Place the Item or Cost  by clicking and dragging the Item or 
cost down into your pricing area. 
To set this up by manually copying the data from your suppliers price lists into a 
spreadsheet or database file, or you can ask your suppliers to provide the data in this 
format. Once set up you can just send them the file twice a year for updating. Keep the 
spreadsheet simple with no formatting as when it converts to a database all formatting will 
be lost anyway. It is a good idea to copy all your suppliers spreadsheets into one working 
file with the various suppliers on seperate tab worksheets. Save this file as say “Trade 
Suppliers Prices” and keep it in your working directory say ...\Suppliers\.

Set Up Data Sources
To setup your Prices spreadsheet as a database go to  File → New → Database
Select “Connect to an existing database”  and use the arrow to select “Spreadsheet” then 
NEXT
Browse for the file you want converted to a database. Then NEXT
Decide how to proceed after saving the database. Select register the database and unselect 
Open the database for editing. Then FINISH.
Save the database with a new name and in the location you want it.
On your Estimating spreadsheet click the Data Sources button found along the 2nd top 
toolbar next to Gallery or press the macro button on the Summary page marked Database 
or press F4 for on/off of Database.
Now click the + to open the database and then click + on Tables. Then click on the page of 
prices you want.
These will appear across the top screen and you can drag and drop them into your estimate 
as required.
To upgrade your database just upgrade your original Trade Prices spreadsheet and save it 
as a database over your old Database file. Click the refresh arrow in Datasources.
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Using Datasources
Click the Database button on the Summary page. Then + Trade Prices + Tables and select 
your supplier. Their prices will appear in the screen. Now just drag and drop into your 
estimate as required.
You can use the Binoculars Find Record to search in really big material lists for specific 
items.
Try to get your suppliers to provide their price lists in an ascii exported file. OpenOffice is 
really good at opening these into a .csv spreadsheet. Then just save this as an .ods 
spreadsheet and manipulate it for a suitable datasource for your program. You can even 
purchase price guides from say Cordells and convert these to Databases.
If you want to close the Data Sources screen click the Database button next to Gallery. But 
next time you open it you will have to go + Trade Prices + Tables and select supplier 
again. Instead right in the middle on the bottom border under the arrows is a little strip that 
when you put your mouse on it says HIDE. Click this to shrink it and then you can reopen 
with the same supplier still open by clicking SHOW.

Delete a Data Source
To get rid of unwanted data sources go to Tools → Options → OpenOffice.org Base (open 
+) → Databases and delete the ones you don't want.

Project Details Page
Access from Summary page by clicking the macro button beside Project Details. This is 
where you would first go to start pricing a new job. Enter all the required information. 
You should have already entered your own business details on the Master Pricing 
Template previously.
There is an area to do a quick Estimate Analysis using known square metre rates. It is 
often a good idea to do this and then give the client a call and suss them out on what their 
expectations are on price. It's a bit hard I know but you sure can flush out the punters with 
not enough money and save yourself a few days of pricing on a job you were never going 
to get anyway.
The information you enter on the Details Page gets auto copied throughout the program 
for you.

Summary Page
View of Summary Page
Most of everything you enter on the Worksheets comes back as a total result to this page. If 
you have started a new project estimate put your mouse on Preliminaries and highlight 
down to Spare 4 then choose a different background colour and save the project in the 
name of the job. Now it takes on its own colour scheme and is easily recognisable from 
others. We will take a stroll around the Summary and see what's on it.

Cells B1 to B3 will be auto filled from the Project Details page.

Cells A6 to A31 have tick boxes. Tick these when you have completed each aspect of the 
estimate so you know when you are completely finished.

Cells B6 to B31 are the Worksheet Names. You can change these to what ever you want 
and this will auto change the names on the Worksheets themselves. BUT you must not 
change the names on the worksheet tabs as these are required by the macros to work. Also 
the Project Report and the UnBilled Report will still give the original names in the lower 
details as headings (the summary headings will reflect your new names). So if you do want 
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to change the names and are happy not to worry about the reports then I suggest you turn 
off the tabs so you don't see them. To do this go to Tools → Options → OpenOffice.org 
Calc → View → Window → untick Sheet Tabs and Okay. 

Cells B33 to D39 are the final calculation areas for the estimate.The white areas are the 
only places that you need to make entries. At D34 you can put a Profit amount or at C35 
you can instead put a profit percentage. Don't do both. Cell B38 you can write in an after 
tax cost which could be say a commission to an agent and enter the amount for this at D38.

Cell E35 gives you a running profit figure provided you have all your invoices and draw 
downs received entered in the program.

Cells E33 to I 33 just provide totals of the columns above.

Google Search Button. This will instigate your browser and take you to a Google Search 
page made by me. Do a search and it takes you to a custom BnQ search page. If you click 
on a sponsored link on this page I receive a small commission which so far has amounted 
to two parts of stuff all. So it is obviously very popular!

Project Pictures. Just double click and you can insert a job picture or an architects 
perspective. Don't load high res pictures as it slows down the loading of the Summary page 
a bit.

Cells A42 to D48 are Macro buttons to take you to custom pages in the program.

Cells B49 to B80 are web site buttons and web site links. You can add custom links here to 
your Pricing Master Copy file. To do this say click on B56 and then go to the 2nd tool bar 
and click Hyperlink. Then click Internet then tick Web and in 'Target' put a web address 
starting with http://  Then in 'Text' type the link name you want and then click Apply and 
Close. You should now have a hot web site link.

Builders Exclusions is an area where you can add items that you wish to exclude as you do 
the estimate. Builders Inclusions and Provisional Cost items are for similar type entries. 
These are just reminder areas for when you type up the quote and specifications. 

Items to check before finishing quote. Once you do most of the estimate but are say 
waiting on the painter and plasterer quotes you can jot these notes here to remind yourself 
that the quote is not finished and as to what you are waiting on.

Cells B81 to J107 is another area to put in reminders as to what is still required to finish 
the estimate.

Tax Calculator. 
GST (goods and services tax) (or any other country's tax system VAT, Sales Tax etc)
All the worksheets are designed to have prices entered excluding tax. The tax is added on 
the Summary page at D37. This safeguards that the entries you make always have tax 
added and not left out. The worst that can happen is that an entry is put in with Tax and 
then has Tax added again. (do this too often and you won’t get the job – however you 
won’t loose money because of Tax issues either). The Tax Calculator will calculate the tax 
throughout the entire program based on what is entered in cell K44.
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Progress Payments Received Including Tax. Here you enter your main receipts of draw 
downs on the project.

Extra Payments received including Tax. Here you enter all those other small extra 
payments that the client has been billed for. The result of this area will go to cell K20 to be 
included in that total.

Client invoice Details. Here you can keep a track of what invoices have been issued to the 
client and which ones have been paid.

Contract Draw Down stages. Enter these based on your contract details. 

And so thats a rap for a run through the Summary page details.

Composite Pricing
Start up Easy-Pro Template and save it as a practice job (practice.ods). Then go to the 
Pricing page. Access this page from the button on the Summary page or from buttons on 
various worksheets. With this page you can set up your own composite rates. Instead of 
just costing each item of a job, you can build up a database of composite rates for various 
jobs based on your knowledge of the time it takes, the cost of materials and the cost of the 
trades involved. With this composite rate in place the next time you price a job you can 
just use this rate. I have set up this page with a list of jobs that would be common on a new 
home or renovation. I have used these rates myself which I have built up from various 
projects. You need to adjust these rates to your area and costs associated to your area. Do 
not use the rates shown as they are probably out of date and you will work differently to 
me.

To start with I had a basic room area of 50 sqm or say 7m x 7m. I then worked out what 
the cost would be to build say the subfloor, or lay the sheet flooring or the walls etc to this 
area. The result of each of these would then become a composite price to use on a lineal 
metre or square metre basis. This rate could then be applied to any project that was similar 
to my costings at the composite rate. You may be a commercial builder who does this 
based on a small factory. Or a project home builder basing it on a particular home size.

So the Composite Pricing page works like this. Turn off Protection so you can see the 
formulas. Cells A7 to A33 provide a summary result of the workings below. Click on D10 
and you will see it says “=E63”. So now go down to Row 63 and you will see that there is 
a calculation for Sheet Flooring. So starting at A57 I have listed all the costs involved in 
putting down sheet flooring over a 49sqm area. These are then totaled by the formula at 
E62 and then at E63 it divides E62 by 49sqm to give a sqm rate. So we just copy this to the 
upper summary by putting “=E63” in the summary rate cell of D10. So whenever we 
update the rates for Sheet Flooring this automatically changes the rate at the upper 
summary at D10 on the Pricing page. Now we take this another step to make this even 
easier for referring to it when pricing a job.
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Now push the Carpenter Button at G1 or at G114 etc. This takes you to the Carpenter 
worksheet. Turn off Protection so you can see the formulas. Click on E6. The formula is 
“=Pricing.D10”  This means the cell is copying the result from the Pricing page and 
putting it here in the Carpenter page for easy reference. 

View of Carpenter WorkSheet with database open.

Lets make an entry on Carpenter for Sheet Flooring. Go to cell B6 in the Per column. It is 
already set at Sq Metre but click the arrow anyway. A drop down list appears that allows 
you to choose from many options. (the help only shows on the top few) Stay with Sq 
Metre. Don't worry about entering anything in Labour or Materials columns because we 
are using the Other column which has the composite rate pre set. So now click on cell F6 
and enter 100 (for a 100 sqm job) then click out of this cell, or hit Enter. This blanks out 
the num? and leaves 100. In the Total column it has added Labour + Materials + Other and 
multiplied the result by the xUNIT column. So our result is $1748.98. Now click the 
Summary button and you will see this result is on the Summary page opposite Carpenter. 
Scroll down and you will see that it has had Profit and Tax added to give you a final result.

Now scroll back up and click the Carpenter button to take us back to Carpenter. Hover 
your mouse over A6. See it is a link. Click it and it will take you back to the Pricing page 
and exactly to your composite workings for Sheet Flooring at A57. So this means when 
you are pricing a job and working in Carpenter doing the Sheet Flooring estimate, you can 
quickly jump back to check on, or adjust your costings for this particular job. If you want 
to adjust them for all future jobs then you should have your Master Pricing Template open 
at the same time as well and fix it too, or make notes and upgrade it later.

Still on the Pricing page, in column D the Rate column, you will see that any carpenter 
labour $'s is green and any pine framing timber $'s is yellow. This is to show that these are 
also =copy cells. Go to cells H8 and H9. Change these rates to your standard hourly and 
day rates, enter or click out of the cell. Now see that all the rates in the Pricing area have 
changed accordingly and also the Carpenter page rates have changed in unison. Do the 
same with cells H14 and H15 for the cost of pine framing where you live. This also 
changes all the costings that have pine framing in them. Click on H8 again and look in the 
cell NAME box that is on the upper toolbar 3rd row down in the far left corner. It says 
“carp_hr”. So you can refer to this cell by entering “=carp_hr” into any cell in the program 
and it will show the hourly rate that you enter at cell Pricing.H8, the carp_hr cell. Try it out 
on the Carpenter page say on LABOUR cell C12 type in    =carp_hr    and click out. It will 
now show $50.00 and will update automatically whenever you change the hourly rate in 
the cell at Pricing.H8 
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Nails 1 say $25.00 $25.00
Labour  6 Hr $50.00 $300.00
Total $857.00
Per SQM rate is $17.49
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Back on the Pricing page, go down to cell A256. Here you will find a Door Cost 
Calculator. Same deal, just set this up with the cost of the various doors and components 
you usually use and you have a quick calculator for working out the doors on a job. In 
column B Qnty put in a few numbers. You now are showing a Doors Total at E294. Now 
go to Carpenter. A19 Item is Door Calculator. At E19 will be the same figure from 
=Pricing.E294. So all you have to do to trigger this into an entry in the Total column of 
Carpenter, is to put  1  in the xUNIT column at F19 and enter or click out. 

This is a view of only part of it.

You can also use the Pricing page to store lists of materials and prices instead of using the 
database. Or use both. From the above information you can see how easy it is to customise 
this program to suit your own business and make a very efficient estimating template.

WorkSheet 
View WorkSheet with Concrete Calculator 

Access by the WorkSheet button on the Summary page or from Concretor etc. This is a 
page that has a couple of concrete calculators and some converters when you scroll down 
lower.

The first concrete calculator, Concrete Quantities Calculator, will work out the cubic 
metres of concrete you need and it will have a crack at working out the amount of 
reinforcing mesh and bar chairs you need. Just enter the measurements in the white cells 
and the results will show up in the green cells. Total Concrete at G21 will then go to the 
Concretor page into the xUNIT cell at F8. To trigger this into Total you will need to enter 
into cell D8 the per cubic metre cost of the concrete. The reinforcing mesh results you will 
have to enter manually into the reinforcing page. You should double check the mesh as 
you may need more or less depending on how it cuts for wastage.

The second one, Composite Concrete Slab Calculator, works the same way as we did on 
the Pricing page. But these costings are based on the concrete slab drawing to the right. 
The end result is a Sq Metre rate for a concrete slab similar in design to the drawing. You 
just need to set up your rates to suit and add or remove items that you require. The final 
figure at G65 goes to Concretor at E19. Just add the figure in the xUnit column to obtain a 
total. This calculator works very well and saves a lot of time on the smaller slabs. On big 
jobs you will of course be getting a quote from a subcontractor anyway, so it won't be 
needed. But now you can see how easy it is to set yourself up with some quick pricing 
systems.
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4 Panel Cherry wood door 2340 ea $0.00
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UnBilled Costs Report
I developed this when I had a very large home to build on a cost plus basis. I needed a way 
to track all the invoices that were due to be paid by the owner. Each of the Trade 
worksheets has an area to enter invoices when they are received. Go to say Roofer and 
move across to Invoiced Actual Job Costs. If you enter a figure in column J, Cost Incl Tax, 
then it will auto fill columns K, L and N. You only need to enter the invoice date in 
column M. In column N you will see the word  **UnBilled** pops up. This tells the 
macro report, UnBilled Costs Report, to look for all  **UnBilled** costs to the client and 
do a report on them. Once an invoice has been charged out you simply got to each Trade 
worksheet and copy and paste from cell P6 the word “Billed”. Now any invoices with 
“Billed” in the N column will not show up in the report. Click on an empty cell in column 
N. you will see an “=If(etc)” formula. If you muck up a cell or want to change it back from 
Billed to Unbilled, then just copy and paste this formula from another cell.

Enter some invoices on a few of the Trade worksheets then go to the Summary page and 
click the UnBilled Costs Report button. The figures will already be showing in the 
Summary area on this page but they won't be showing in the lower details area. So click 
the Load/Refresh button and wait. Then a popup will appear saying that a file has been 
created and saved as an unbilled.csv  You can recover this file and use it to import into 
accounting programs or make another spreadsheet if you wish. But remember each time 
you press Load/Refresh it will copy over it unless you save it in a different name or move 
it. When you close the popup and scroll down you will see that every entry that you made 
in the invoice area, that was marked as UnBilled, is now in this report. You can print this 
out and compare it with the report from your accounting program.

On this note of accounting programs. Many builders try to buy estimating programs that 
then blend all the budgeting and estimating and invoicing into the one package. Programs 
like Quick Books and many others have all tried to have this ability for builders. I find 
they are great programs for accounting but are very difficult when you want to extract 
specific and reliable job cost/profit information. To overcome this I have used a double 
entry system. When an invoice comes in it is then entered in the accounting program and 
marked on the invoice as “√ QB” , then it is entered also into the specific job Easy-Pro 
estimate and again marked “√ SP”. This double entry system is excellent for finding data 
entry errors and omissions in both the estimate and accounting programs and you can refer 
to both to find any discrepancies. Especially when doing a cost plus job. With these any 
invoice that is not accounted to this job is money lost as it won't be billed out to the client. 
If you are only using an accounting program to track your invoices it is too easy to have an 
invoice for a cost plus job get absorbed into the accounting for another quoted contracted 
job and then you have lost that money because it won't show up in the accounting program 
report that the invoice has not been billed out.

Project Costs Report 
View Project Report

To access this click the Project Report button on the Summary page. This does a very 
similar job to the UnBilled report above. But what it shows is every entry that you place in 
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the main estimating areas of the Trade worksheets. The reason for this report is to provide 
you with an easy way to print out the details of your finished estimate. 

Printing Tips
NEVER click the Print button on the top tool bar and NEVER go to File → Print and just 
press Print. Because what will happen is the print spooler will start trying to print out a 
hundred + pages of this entire spreadsheet. The Project Costs Report is a neat black and 
white report of all your entries that prints out on a few pages of A4. Follow the prompts or 
tips on both the UnBilled report page and the Project report page to make printed copies. 
Anywhere else in the spreadsheet that you want to make a print of, then you need to 
Highlight the area you want to print then go to File → Print and click “Selection” so that 
you are only printing the Selected Highlighted area. How many times have I stuffed up and 
started a process of printing this entire spreadsheet. Heaps. And then it means stopping it, 
deleting the job in the print spooler and wiping the job from the printers memory. So 
follow my advice on printing and only print selected areas or use the Project Costs Report.

Trade Worksheets
If you wish to change the name of the Trades then do so on the Summary page B6 to B31 
as this changes them throughout the program. As mentioned before, if you do this then it's 
probably best to turn off the tabs by Tools → Options → OpenOffice.org Calc → View – 
Window – untick Tabs. The reason for this is that the Tabs need to remain in the existing 
names for the macro buttons to work. Because every page has a macro button you don't 
need to see or use the Tabs to move between sheets. The only difference will be that the 
UnBilled Costs report and the Project Report lower details will reflect the original names 
but the Summarys on these reports will reflect the new names you chose.

I will work down through some of the Trade Worksheets as to how they are used and once 
we have done a few you will have got the hang of it and will not require me to go through 
the whole lot. In estimating any job whether it is a large commercial job or a small 
renovation, there is a mixture of work that you need to estimate. Some sections of the job 
can be let out to subcontractors and so you will just obtain prices from these guys and 
simply put the quote into the trade sheet. Say Painting you get a quote for the whole job 
and the painter is organising his own scaffold etc. So your only entry on this page will be. 

But other Trades sheets will require you to work out a multitude of labour and material 
costs and will also include quoted rates. Bricklayer is a good example where the brickies 
will usually only provide a rate to lay bricks that might cover some scaffolding and that's 
all. So you will have to work out all the costs of the bricks and ancillaries associated with 
this trade.

View Bricklayer WorkSheet 
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Painting
ITEM Per Labour +Materials + Other x Unit =  Total

Domestic and Commercial Inc Paint Coy. Quoted $28,560.00 1 $28,560.00
Extras Each 0 $0.00
Scaffolding Estimate 0 $0.00
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Insert Cells button

On each Trade sheet is a macro button named Insert Cells. Also on the sheet is a cell at say 
A28 that says  Leave these cells blank for cell inserts.  In the Invoices section there  is also 
a similar setup. These macro buttons do as follows. 1/ turns off protection 2/  inserts six 
sets of cells 3/ copies the formulas and formats into the new cells 4/ turns back on 
protection when you click Okay(no password) on the popup box that ends the process. 

The benefit of this button is that it makes it easy for say your bookkeeper to insert more 
cells in the Invoices section when they are inputting data without having to find someone 
with the spreadsheet ability to do the process for them.

Provided you don't type over and use the cell with  Leave these cells blank for cell inserts 
in it, then the macro button should always do the process for you.

Inserting Cells Manually

Say you are on the Preliminaries page and at cell A10 you would like to insert 5 blank 
cells across the estimating area. Then do as follows.

1/  Turn off Protection    Tools → Protect Document → Sheet untick

2/  Click on A10 and holding left button down slide your mouse to G15 then let go of 
button.

3/  A10 to G15 will be highlighted. Hover your mouse over the highlight and right click 
mouse and select Insert. A box will popup so select Shift Cells Down and Okay. You now 
have 5 new entry rows but these are devoid of formulas and formats.

4/  Go to an original area of cells with no data yet entered and highlight say B20 across to 
G20. Hover mouse over the highlighted cells and right click and select Copy (or Crtl C). 
You are copying the formulas and formats from these cells to the new inserted cells.

5/  Now highlight the new cells of B10 to B15 (not B10 to G15) Hover mouse and right 
click and enter Paste (or Crtl V) The new cells should now have all the formulas in them.

6/  Turn Protection back on Tools → Protect Document → Sheet tick and the Okay with 
no password in the box.

Now you have 5 new cells across the estimating area with all the formulas in place. The 
Total formula at the bottom automatically adjusts to add up all these as well.

Preliminaries

This is where you would normally start an estimate. You will see that I have already listed 
a lot of items. So you will have set up your Master Template with these edited and added 
to ready to go, so it is just a matter of entering the rate for each now. The first thing I 
would do is run down the list and start my entries in the Per column. Say there was no 
Town Planning fee. Click the Per column and then the down arrow. From the list select 
either “N/A” or “Owner Paid”. Then repeat this for all the items you are not including. If 
something is obvious that it either needs to be included, or excluded, but the tender shows 
otherwise, you will have to note this in the quote. So go to the Summary page and enter it 
in either the Exclusions, or Inclusions area as a reminder for later on.
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Say you need to enter a rate at Home Owners Warranty. In the Per column I would select 
“Per” but you don't have to use a selection, you can just write in your own. Then as this 
fee is not LABOUR and not MATERIALS I would enter the insurance rate in the OTHER 
column. As soon as you do this the “num?” shows up in the xUNIT column. Just enter 
number 1 in it and the TOTAL column is now triggered with the entry. Then just repeat 
this for all entries. The only time I ever use the LABOUR or MATERIAL columns is 
when the Item is actually only one or the other. If a suby is giving a quote for both 
combined then I would put this in the OTHER column.

With the Project Management, Supervisor and Contingency Items you can either have a 
guess now and adjust later, or wait until the estimate is near complete before entering 
these costs in the OTHER column. When the estimate is near complete, look on the 
Summary page at D33 Sub Total excl Tax and then use that as a basis for calculating the 
amount that you wish to apply these fees to. This might be say $350,670 x 5% but you 
know that you have applied approx $7,600 of contingencies to some specific trades 
already and you want to take the kitchen out as well which is a PC of $25,000. So the 
figure you put in for Project management might be $300,000 x 5% because you want to 
win the job. You don't have to use the percentage in the xUNIT column. You can make it 
enter a normal number by just copy and paste one of the cells above in the xUNIT column 
that has the “num?” formula in it. This changes the format as well so the number 1 will be 
1 not 1%. This way in say Supervisor you can enter $5,500 in OTHER and 1 in xUNIT to 
= $5,500 in the TOTAL column rather than as a percentage derived result.

Equipment Hire

We will skip Demolisher because I reckon you have got a handle on all this already. On 
the Equipment Hire page I have listed all sots of equipment that might be hired, well by 
me anyway. You will have changed a lot of this on your Master Pricing Template and 
added all your local hire companies current rates for quick reference. Now it is simple and 
quick to make your entries here as mostly you only need to put the days, or weeks in the 
xUNIT coloumn. With Scaffolding you might already know your suppliers rates for a 
smaller job or you may be getting a quote which you will now enter in. Pretty simple now 
isn't it?

Lower Calculations Area

This sits below the main estimating area on every Trade worksheet. Any entries here DO 
NOT go into the estimate and end up on the Summary page, unless we make them by 
using a “=Cell” formula in the estimating area above. This area is where you can expand 
on the upper main Items. Say you have a lot of Item entries for your scaffolding 
requirements on this job. You can enter them all down here in the Calculations Area then 
total them up and put a summary of this in the Estimating area above. In the upper Item 
you might write “Scaffolding All types See below”    OTHER = $25,500  xUNIT = 1 
TOTAL = $25,500.

But in the Calculations area you might have 20 entries describing Mobiles, Cherry pickers, 
Quick Stage, Material Hoists, Labour etc. Then you would have used a Totaling formula 
to make a total of these. Then in the main Estimating area you would have in the OTHER 
column the “=cell” formula to copy the total up there. You can see this working on the 
Bricklayer page in relation to brickies sand. Go to the Bricklayer Trade sheet. See Sand 
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and cement sundries – MATERIALS cell D21. This is copying the Total up from the 
Calculations Area below where I have put a number of Items that make up the sundries a 
bricklayer requires at a per 800 bricks rate. Another page that has an example of this setup 
is the Carpenter sheet. See how I have put all the beams and lintels in the Calculations 
Area below and set up the Total of these to go to the top cell at G73 which is then copied 
at D36 in the main area by the “=G73” entry.

Quick Tip on Sum Totals

Here is an easy way to get a quick Total entry in a cell of items in the Calculation Area. 
(Do not do this in the upper main estimating area.) Still on the Bricklayer page as a demo. 
Turn off Protection (Tools → Protect Document → untick Sheet). Put your mouse on G36 
in the TOTALS column of the Calculations Area. Now holding the button drag it down to 
G42 highlighting these cells. Let go of the button and move the mouse up to the SUM 
button on the lower toolbar at the top. (It looks like Ʃ). Click this and it will add the cells 
from G36 to G41 and put the Total in G42 where you stopped. Now to copy this up to the 
main estimating area we just go to D21 and put    =G42     in it. This then copies the result 
up here. Now when you work out how many bricks you are going to use. Just divide this 
by 800 (if your bricky uses this calc) and put this figure in the xUNIT column at  F21. So 
this shows you how the Calculation Area can be easily used to expand on the estimating 
area items and then have the result copied into it.

Using the SUM box

Whilst we are on getting totals. In the very bottom right corner of the spreadsheet is a 
SUM box that will have “Sum = 0”  or Sum=$40.00” depending on which cell you are 
currently in at the time. Now still on the Bricklayer page go to cell G36 and drag down 
and highlight to G40. Let go of the mouse and look in the SUM box. It will have the 
addition of those cells you just highlighted shown. 

Say you wanted to only add G36+G37+G40. Hold down the CRTL key and put your 
mouse on G36 and highlight to G37 then let go of the mouse button and move to cell G40 
and click on. Now let go of CRTL. The result of those 3 cells only, will be in the SUM 
box. These functions are handy to know as you will use them a lot to check on various 
parts of your estimates. Highlighting all the cells in the TOTALS column of the estimating 
area and checking the result in the SUM box is a great way to check that all the Totals 
formulas have worked for that page. You can do this anywhere in the program even on the 
Summary page to check the Totals calculations are correct. It is a very good idea to do this 
before you finalise an estimate, especially if you have had Protection turned off on some 
pages.

Escape from trouble

Sometimes when you are mucking around in say the TOTALS area with Protection off, 
you might start to drag a formula. By this I mean you will see the formula displaying in the 
cell in various colours and it might be adjusting as you move your mouse. This just means 
you have grabbed the formula to edit by mistake and the spreadsheet thinks you want to 
adjust it by following your mouse around. Just take your finger off the mouse button and 
click the ESC key. The formula should return to original, but just check it is okay anyway. 
Turn Protection back on to prevent these accidents from happening. If you think you have 
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mucked up something and the program has not saved yet. Go to the reversing button on 
the top toolbar. It is a curly arrow above the Bold button. The curly arrow will reverse any 
entries 1 at a time up to about 5 entries ago. So it is a good way to reverse any big stuff 
ups.

I reckon by now you have got a pretty good grip on how to enter data into the Trade sheets 
so there is no point in going over any more as it is just repetition from here.

Other Add on Sheets
These are the sheets like Order Forms, Invoices, Home Loans, Floating Frame, Time 
Sheets etc. Each of these has a lot of help on each sheet that will guide you through how 
to use them if you choose to.

Gantt Graph Schedulers
These will draw a handy Gantt graph as you enter the time frames for the various Trades 
in the Forecasted and Actual time frames of the project. You can then work out when you 
will need to notify tradespeople to be on site and when you are going to request draw 
down payments. There is a lot of help written on these pages so no point in going over it 
again here.

Roof Works 
Every Builder/Carpenter in the country has a Hancocks roofing book in their car. These 
are a great resource but what they don't do is work out exact rafter lengths and cuts when 
you get those renovation jobs with a roof pitch in between the pitches in the book. Also 
over 6 metres you have to add figures up and it restricts you to 500crs on the creepers.

I have designed this Roof Cutting Calculator to do all this for you in a quick spreadsheet 
form. It only requires 4 entries of Rise per Metre or Pitch degree, desired Creeper spacing, 
Half span and Roof overhang. Once entered you will then have results for Rafter lengths, 
Hip lengths, Creeper reduction, Angle cuts etc.  There is also a batten calculator and a 
Ridge length calculator.

Scroll down to view a copy of this.
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United States and Other non-metric Countries
Imperial Measurements Entry are easy.
You will need to make sure that you untick the auto replace function otherwise 3/4, 1/2, & 
1/4 will appear as 3/4, 1/2, 1/4  and then be recognised as text. To do this go to 
Tools → Auto Correct → Options → Untick Replace 1/2 with 1/2 

To enter say 6ft 6inches, type in the Unit column of the trade worksheet 6(space)6/12  The 
spreadsheet will then alter this to the smallest fraction of 61/2. The decimal equivalent of 
the result will be in the formula bar at the top showing 6.5. The spreadsheet will multiply 
61/2 by the Rate in $ or £ depending on your country version. You can do the same with 
inches and fractions of an inch, 51/4 inches enter as 5(space)1/4.
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Enter Roof Section 1

Calculate Rise and Rafter Length 4.24
26 Roof Pitch in degree 26.57
34 3.000

Result is Pitch in Decimal Degrees 26.57 0.600
Result is the Rise per metre 0.500 Rise to top = 1.500
Calculate Pitch Degree from Rise Rafter Length = 3.354

0.500 Rafter + overhang = 4.025
Pitch in degrees = 26.57 Hip and Valley Length = 4.500

Hip overhang length = 0.900
Creeper reduction per pair 6.000 Hip + Overhang Length = 5.400

0.500 0.300 0.85
Reduce each creeper by 0.559 Deduct ½ Ridge thickness from Rafter lengths

measured square back from plumb cut.
Using a 100mm timber mark setbacks for cut angles Cut Setbacks for the 100mm Guide

A = Plumb Cut Hip 0.035
B = Down Cut Purlin 0.045
C = Plumb Cut Rafter 0.050
D = Mitre Cut Purlin 0.089
E = Side Cut Hip 0.106
F = Side Cut Rafter 0.112

Ridge Length Calculation
Enter building length of top plate 11.000
Span of building 6.000
Thickness of Ridge beam 0.045
Result is the length of the Ridge 5.045
 

Batten Quantity Calculation includes overhang Material check list
Enter Batten spacings wanted 0.760 Rafters

5.296 Ridge  
Sqm Area of this roof is (incl o'hang) 99.348 Hips

110% Purlins
Battens in Lin metres – (incl hips) 201.141 Purlin Props
Battens in Lin metres – Gable roof 168.983 Collar Ties

Battens
Bracing
Ceiling Joists
Hanging Beams
Metal fasteners & tie downs.

Convert   xº xx'   to Decimal Pitch & Rise per m
Enter Degrees    optional

Enter Minutes     optional Enter Half Roof Span      required

Enter Rafter Overhang     required

Enter Rise per metre       required

Enter Creeper spacing    required

But result is – so adjust above. See note

Allow a waste factor – (enter as  110%)

100

BA
E

C D E F



Use Freeze and New Screens
This is pretty basic for spreadsheet users but it's something even I forget one can do at 
times. Open up the Carpenter sheet. On the far left click on the no. 3 Row. This will fully 
highlight across to the right. Now go to the top toolbar and select Window → Freeze. 
Now scroll the page down and you will see that all the headings remain at the top for easy 
reference. Just do the reverse to turn it off. You can use Split on the columns to have the 
same effect.

Now go to Window → New. This has now created a linked duplicate of the estimate you 
are on. Every entry you make to one goes into the other and visa versa. So say you want to 
fill out the order form using entries you have made as Items in Carpenter. Then just have 
one view on Carpenter and the other on Orders and copy and paste between. Whilst on 
Orders another way you can fill these in is by opening up your Datasource and just drag 
and drop the Items in from your database of the suppliers list of Items. Another way you 
would use this is when you are working out Concrete and Reinforcing. You can make 
entries into each with both open at eh same time.

Developers Notes
Building in Cairns at the time, I bought my first computer estimating program for $14,000 
running on an old dos pc. It was way too complex for the average builder and I soon gave 
it the flick. Lotus 123 was fairly complex too but then Quattro Pro appeared and I was 
soon able to build myself a suitable estimating program from it. Moving back to 
Melbourne and setting up a business here, I used a number of programs like Buildsoft and 
Cordells and downloaded plenty of demos of others to try out. Some are great programs if 
you are a full time estimator, but price and performance just didn't meet the demands of 
my business and the time I had available for estimating. So then I redeveloped my old 
program into Excel. A few people who looked at it suggested I should sell it. So I did for a 
while but the more features I added the slower Excel became to the point it was unusable. 
Then I tried OpenOffice which for the same program had a file size about ¼ of Excel and 
so much faster. This meant I could keep adding the features I wanted to where it is in its 
present form today. 

The program has been sold into many countries throughout the world and into some pretty 
remote spots. It is amazing to have engineers in Saudi Arabia and Dubai, a large project 
home builder in Canada, a charity in Zambia, a builder in Israel, amongst the many users 
of the program. It has been mainly sold into Australia, UK, Ireland, Canada, New Zealand 
and the USA. My son found out his teacher at trade school was using Easy-Pro. I have 
since donated copies to many TAFE colleges.

No one likes to pay too much for anything over the internet and I am one of them. But I 
can assure you that there has been hundreds of hours of development gone into this 
program and I have had a software programmer in India develop the reporting functions 
which would have cost a few thousand dollars if done here. Add to this just the work 
involved in the latest upgrades and writing this manual and you could not build this 
spreadsheet yourself for less than a few thousand dollars and only paying yourself $25 per 
hour. 

Cont....
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But the best part of this program is that it can be customised by you, to suit your business. 
You are not locked in to a developers format that only allows you to estimate their way. 
Further more the base of Easy-Pro is the OpenOffice Calc spreadsheet that has had 
millions of dollars spent in development and OpenOffice will continue to upgrade the Calc 
spreadsheet for you for free.  Easy-Pro Estimator provides you with the office tool that you 
need to develop your business to the next level and beyond, at a fraction of the price of the 
big named programs out there and make the very difficult job of estimating just that much 
more easier and efficient.

If you have not already done so.
Click here to Purchase.

Good luck with your building business and thanks for taking the time to read this through.

Robin Guymer

Email: buildnquote@pacific.net.au

Web Site :  www.buildnquote.com
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